Back
Maintenance

Routing Software Updates

Completed 3 Jun at 08:30pm UTC.

ingress-fmt2-1.kerfuffle.net DNS a.ns.kerfuffle.net DNS b.ns.kerfuffle.net ping ntp.kerfuffle.net MySQL Cluster Health
Completed

Maintenance completed

Posted 3 Jun at 08:30pm UTC.
Started

Mikrotik :/

Posted 3 Jun at 04:30pm UTC.